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Tutoriel IMOD 

François Orange, Michaël Trichet et le groupe de travail « Analyses d’images 3D » 

Contact : francois.orange@univ-cotedazur.fr , michael.trichet@sorbonne-universite.fr 

Ce document n’a pas pour but de remplacer l’aide officielle de IMOD, qui est disponible 
en ligne, mais de fournir un exemple de méthodologie et des petites astuces. 

N’hésitez pas à nous signaler toute erreur ou question !  

Index de l’aide officielle IMOD : https://bio3d.colorado.edu/imod/doc/index.html 

 

Installation  

Ce paragraphe décrit l’installation sur un PC (Windows 10) et sur Mac (OS supérieur à 
10.11). Pour les autres configurations (Linux), la procédure d’installation est décrite sur le site 
d’IMOD (https://bio3d.colorado.edu/imod/doc/guide.html ). L’installation sur PC n’est peut-
être pas la partie la plus simple à faire (il y a quelques petites étapes techniques), ni la plus 
simple à décrire (mes excuses par avance). L’avantage, c’est qu’il n’y a besoin de le faire qu’une 
seule fois. Ensuite, on est tranquille. L’installation sur Mac est plus simple puisqu’il s’agit de 
l’environnement Unix dont IMOD a besoin. 

Plusieurs configurations sont possibles, et sont décrites sur le site (voir lien ci-dessus). 
Personnellement, sur PC, j'utilise IMOD par le biais de Cygwin. Pour cela : 

1) Pour PC uniquement :  
- La première étape est de télécharger et installer Cygwin qui émulera un 

environnement Unix. Récupérer l’Installer 64 ou 32 bits à ce lien : 
https://bio3d.colorado.edu/imod/doc/guide.html#SettingUpWindows 

- Suivre les différentes étapes de l’installation, et les instructions de la page web qui 
s’ouvre. Il est conseillé de renommer le dossier de destination de cygwin64 en 
cygwin, et de le mettre directement sur le disque C:\ ( C:\cygwin ). A l’étape Select 
Package, modifier Default en Install, comme précisé. Demander à ce qu’un icone 
soit mis sur le bureau (c’est ce qui servira à lancer IMOD ensuite !) 

2) Pour PC et Mac :  
- Télécharger et installer IMOD (https://bio3d.colorado.edu/imod/download.html , 

rubrique Latest Stable Release Packages – Windows ou Mac, cliquer sur full 
clickable installer ou clickable installer). 

- Pour rappel, sur Mac IMOD n’a pas besoin de Cygwin 
- Quelle version de CUDA choisir ? CUDA n’est requis que pour les ordinateurs 

équipés d’une carte graphique NVIDIA, à ma connaissance ce n’est pas le cas pour 
les Mac. Pour l’écriture de ce tutoriel, j’ai pris la version avec CUDA le plus élevé, 
sur un PC qui n’est plus tout jeune, et il n’y a pas eu de soucis.  

- Normalement, ça s’installe tout seul 
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Vérification de l’installation 

IMOD se lance en lignes de commandes à partir de Cygwin (PC) ou du 
Terminal (Mac : Applications/Utilitaires/Terminal)  

Pour PC 

- Dans le dossier C:\cygwin\home, il doit y avoir un dossier à votre nom ou au nom 
de votre ordinateur (par exemple : C:\cygwin\home\Francois) 

o Un conseil : créer un raccourci de ce dossier sur le bureau et le renommer 
Dossier IMOD, pour un accès plus facile. C’est le dossier où iront toutes les 
images que vous souhaitez aligner / segmenter / modéliser, et où seront 
sauvegardés les résultats 

- Dans ce dossier, créer un dossier Test  
- Sur le bureau, lancer le Cygwin64 terminal  
- Rentrer la ligne cd Test  

 

- S’il n’y a pas de message d’erreur, tout est bon !  
- S’il y a une erreur, vérifier que les variables d’environnement sont bien définies 

(c’est-à-dire là où cygwin pense qu’est votre dossier d’image, où est IMOD…).  
Tout est expliqué ici :                     
https://bio3d.colorado.edu/imod/doc/guide.html#InstallingWindows , 
(paragraphe After installation at the command line ) 

 

Pour Mac 

- Pour tester l’installation sur Mac il suffira de lancer les commandes etomo ou 
3dmod dans le terminal 

- Normalement les fenêtres respectives se lancent. Je n’ai jamais eu d’erreurs, je 
préconiserais de redémarrer le Mac, voire de réinstaller IMOD en cas de problème. 
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A noter qu’il est possible de changer simplement le dossier à l’aide d’un « glisser/déposer » 
dans le terminal : rentrer la ligne cd puis prendre et glisser le dossier cible depuis la fenêtre 
vers la fenêtre du Terminal : 

 
 
 
 
 
 

 

Le dossier de travail d’IMOD est automatiquement modifié pour celui que vous avez 
sélectionné, pratique ! 

 
 
 
 

 

 

Workflow  

Le traitement des images avec IMOD inclut les étapes suivantes :  

- La préparation du stack d’images 
- L’alignement des images 
- La segmentation (= tracer les contours des structures à modéliser) 
- La modélisation  

 

Préparation du stack 

Il s’agit de mettre ensemble et dans l’ordre dans un stack l’ensemble des images qui 
ont été acquises au MEB ou au MET, et d’en profiter pour faire les ajustements nécessaires 
(inversion des couleurs, suppression des mauvaises images, recadrage…) 

Cette partie-là ne se fait pas dans IMOD  

Dans ImageJ / Fiji : 

- Faire un stack avec les images dans l'ordre 
- Faire toutes les modifications jugées utiles (recadrage, inversion des couleurs, 

enlever les barres d’échelle, normalisation du contraste, suppression des sections 
en mauvais état…) 
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NB : s’il manque des sections, ce n'est pas grave. Il sera toujours possible de rajouter une 
section vide à la place ensuite, et IMOD se débrouille très bien pour modéliser un objet même 
s’il manque quelques sections.  

- Sauvegarder au format .tif. 
o Conseil : Appeler toujours le stack Stack.tif. Ca simplifiera beaucoup les 

choses ensuite. Pour ceux qui n’ont pas envie de suivre ce conseil, il faudra 
IMPERATIVEMENT éviter les espaces et accents dans les noms de fichier. 

- Placer le stack dans un nouveau dossier dans votre dossier IMOD 
(C:\cygwin\home\VotreNom\Nouveau_Dossier ). Dans le but de ce tutoriel, je 
crée un dossier Tutoriel 

 

Alignement 

Avec ImageJ/Fiji : le plugin Linear Stack Alignment with SIFT (Plugin/Registration) est 
automatique et s’en sort en général bien (donc pas toujours) avec les réglages par défaut. 
Attention, ce plugin ne gère que les translations et rotations, pas les déformations/étirements, 
ce qui peut être un souci pour l’alignement d’images faites par Array Tomography. 

Avec IMOD, l'alignement est semi-automatique. IMOD va d'abord chercher à aligner 
les images, paire par paire. Il faudra ensuite vérifier cet alignement et corriger les erreurs, 
avant de redemander à IMOD de refaire un alignement. Ces itérations peuvent être faites 
autant de fois que nécessaire, mais de manière générale, la séquence "Alignement 
automatique > Vérification manuelle > Alignement automatique" est suffisante. 

La dernière étape sera la fabrication du stack aligné 

L’utilisation de IMOD implique de rentrer des lignes de commande. Pas de panique, ce 
sont toujours les mêmes ! Dans la fenêtre de cygwin, vous pourrez retrouver les commandes  
précédemment rentrées avec les flèches haut et bas. 

 

Lancement de etomo 

- Sur le bureau, lancer Cygwin avec l’icône Cygwin Terminal (PC), ou 
Terminal (Mac) 

- Sélectionner le bon dossier, ici : cd Tutoriel   
o NB : Pour remonter dans l’arborescence des dossiers : cd .. 

- Convertir le stack en .mrc : tif2mrc 
Stack.tif Stack.mrc 

o Le .mrc est le format qu’utilise 
IMOD pour les stacks 

- Lancer etomo :  etomo 
- Cliquer sur Align Serial Sections / Blend 

Montage 
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- Charger Stack.mrc et cliquer sur OK 

 

La fenêtre de paramétrage de l’alignement s’ouvre  

Onglet Align (onglet par défaut quand on lance etomo) 

L’aide complète est ici : 
https://bio3d.colorado.edu/imod/doc/serialalign.html#Aligning  

Il y a différentes possibilités pour paramétrer l'alignement 
automatique. Ce qui suit est un exemple de méthodologie. 

Il est tout à fait possible, pour commencer, de laisser les 
paramètres tels quels et de cliquer sur Initial Auto Alignement 

Quelques explications sur les paramètres :  

- Find initial shifts with cross correlation : facultatif, va 
juste essayer de superposer les images successives sans 
jouer sur les rotations / translations / grandissements. 
Peut-être utile en préalable ou pour certains 
alignements rapides. Je ne l’utilise pas en général. 

- Choix entre Rotation / Translation - Rotation / 
Translation / Magnification - Full Linear Translation. 
Pour les deux premiers, ça fait ce que ça dit : ça essaye 
de superposer les images en jouant sur la rotation, la 
translation voire le grandissement. Pour la Full linear 
translation, ça ajoute l'étirement des images dans une 
direction. 

- A mon avis, c'est le Full Linear Translation qui est le 
plus approprié pour la Array Tomography, car il y aura des distorsions liées à la 
coupe à compenser. Pour du SBF, ce serait plutôt l’une des deux premières options 
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- A priori pas besoin de modifier les autres options, hormis Fraction to ignore on edge 
éventuellement (valeur par défaut : 0.05, ce qui veut dire qu’il zappe 5% de l’image 
au bord, ça marche bien, voire mieux avec 0.10 ou 0.15, à essayer) 

- Warping : possibilité de faire des déformations locales. Je n'ai pas compris comment 
ça marche de manière efficace par contre. Donc ce n’est pas la peine de s'embêter 
avec dans un premier temps 

 

- Dans la rubrique Search For, choisir entre Rotation / Translation - Rotation / 
Translation / Magnification - Full Linear Translation 

- Lancer Initial Auto Alignement. Ca va prendre entre quelques secondes à quelques 
minutes suivant la taille du stack. Quand done est affiché dans la barre en haut de 
la fenêtre, c’est terminé 

 

 

Midas 

Midas est le nom du module qui permet de vérifier la qualité de l’alignement 
automatique, et de le corriger. 

- Une fois l’alignement terminé, cliquer sur Midas 
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Par défaut, Midas superpose deux sections successives, l’une en vert, et la seconde en 
rouge. Si l’alignement a été bien fait, les couleurs s’additionnent et donnent du noir (image de 
gauche). Si l’alignement a été mal fait, ça se voit tout de suite (image de droite), et il faut 
corriger manuellement. 

 

Pour naviguer dans Midas, utiliser les petites flèches de la case Reference Sec. en haut 
à gauche. Les deux cases Reference Sec. et Current Sec. affichent les sections qui sont 
comparées. Par défaut, ce sont deux sections successives, mais cela peut être modifié.  

En cliquant et décliquant Toggle Ref/Cur, on ne superpose plus les images en 
rouge/vert, mais on affiche alternativement les deux images (très pratique !). Pour revenir à 
l’affichage rouge / vert, cocher Overlay view. 

- Faire défiler le stack dans Midas pour comparer toutes les paires d’images 
- Si nécessaire, ajuster manuellement l’alignement entre les 

paires d’images. 
o Pour cela, utiliser les outils dans la colonne de 

gauche pour ajuster la position (X/Y translation), la 
rotation, le grandissement (magnification) ou 
l’étirage (stretch) 

o Pour des petits ajustements, cela se fait assez 
simplement.  

o On peut utiliser la souris (click gauche enfoncé) 
pour corriger la X/Y translation 

o Si eTomo a fait n’importe quoi, ça peut être très 
compliqué. Pour s’y retrouver, regarder les déformations appliquées dans 
la colonne de gauche. Dans la plupart des cas, eTomo a fortement modifié 
le grandissement (valeur de Magnification très différente de 1). Pour s’en 
sortir, remettre cette valeur proche de 1, et éliminer un éventuel étirement 
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- Important : après chaque modification, cliquer sur S pour 
sauvegarder. Un petit message s’affiche  

- Une fois toutes les corrections faites, fermer Midas 
- Cliquer sur Refine with Autoalignement, pour refaire un 

alignement avec les modifications apportées dans Midas 
- Vérifier à nouveau dans Midas que tout va bien 

Dans la pratique, on peut s’arrêter là la plupart du temps. Mais rien n’empêche de faire 
autant de cycles Alignement automatique / Vérification sur Midas que l’on veut.  

- Si jamais on veut tout recommencer : cliquer sur Revert to No Transform 
 

- En haut de la fenêtre, cliquer sur l’onglet Make Stack pour passer à la suite 

 

Onglet "Make stack" 

Maintenant que l’alignement est fait, cet onglet sert à 
paramétrer la fabrication du stack aligné. 

Il y a différentes options : Local Fitting / Remove trends in 
translation / Remove trends in translation & rotation / Global 
alignement. Pour les différences entre chaque, je vous renvoie à  
l’aide officielle 
(https://bio3d.colorado.edu/imod/doc/serialalign.html#Images ). 
Contrairement à ce qui est mis dans l’aide, j’ai une préférence 
personnelle pour l’option Global alignement, qui semble donner 
les meilleurs résultats. Mais je recommande également d’essayer 
les autres options, pour voir ce qui fonctionne le mieux.   

- Avec le Global Alignement, il est possible de mettre une image de référence. La 
plupart du temps, ce n’est pas spécialement utile.  

- Size in X Y : taille en pixel du stack final : ne pas hésiter à mettre une taille plus 
grande que les images initiales pour être sûr de ne rien perdre (par exemple 1500 
x 1500 pixels pour des images d’origine à 1280 x 1280 pixels) 

- Cliquer sur Make Aligned Stack 

 

- Pour ouvrir le stack aligné, cliquer sur Open Aligned Stack 
o Le stack aligné est sauvegardé sous le nom Stack_ali.mrc 
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Une nouvelle fenêtre s’ouvre : 

- Pour lancer et arrêter le défilement automatique : clic droit 
- Pour naviguer entre les sections : page précédente / page suivante  

 

Comment s'assurer que l'alignement est bon ?  

C'est une très bonne question ! En cherchant dans la littérature et les études utilisant 
l’Array Tomography (la technique la plus à même de produire des biais d’alignement), je n’ai 
pas vu que les auteurs utilisaient des critères spécifiques pour vérifier et justifier la qualité de 
l’alignement. Par défaut, je dirais donc que c’est une question de ressenti (« Est-ce que 
l’alignement vous semble bon ? »). 

Dans IMOD, un moyen simple peut-être d’utiliser les vues orthogonales (sur le stack 
aligné Image > XYZ, en ayant auparavant rentré l’échelle en Z avec Edit > Model > Header, 
voir partie suivante sur la segmentation pour plus de détails sur ces fonctions), en regardant 
par exemple si des objets qui doivent être ronds (vacuole, vésicule, mitochondrie) le sont bien 
sur les vues orthogonales. 

 

Transition alignement / segmentation 

Dans l’absolu, il est possible d’enchainer directement alignement puis segmentation en 
segmentant le stack aligné Stack_ali.mrc 

Mais vous pouvez aussi avoir envie : 

- De vous arrêter là, et exporter le stack aligné 
- De faire des modifications sur ImageJ sur le stack aligné (par exemple insérer des 

images vides dans le stack pour remplacer les sections qui ont pu être perdues).  
 

- Pour exporter les images au format tif, 
il faut taper la ligne de commande : 
mrc2tif Stack_ali.mrc Stack_ali.tif 

 

Seul petit défaut de cette commande, le stack est exporté sous formes d’images 
individuelles. Les fichiers sont sauvegardés dans le dossier IMOD.  

- Une fois les modifications faites, sauvegardez les résultats sous un stack Stack.tif, 
et placez ce stack dans un nouveau dossier. 

De manière générale, je conseillerais de faire la segmentation dans un nouveau dossier 
: s’il n’y a pas de modification à apporter au stack aligné, il suffit de copier/coller le fichier 
Stack_ali.mrc dans le nouveau dossier, et de le renommer Stack.mrc 
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Segmentation 

Principe  

Sur chacune des sections, il s’agit de tracer les contours des objets à modéliser en 3D. 
La segmentation et la modélisation se feront avec 3dmod, un des modules de IMOD 

Interface 3dmod 

- Pour ouvrir 3dmod, taper la commande suivante : 3dmod Stack.mrc (PC), ou 
3dmod (Mac). Dans ce second cas une fenêtre s’ouvrira dans laquelle vous pourrez 
sélectionner vos fichiers (le .mrc dans Image file et le .mod dans model file). 

 

- Dans l'interface de 3dmod, il y a la fenêtre principale où est affiché le stack, et une 
petite barre d'outils 

 
- Quelques fonctions utiles :  

o Pour naviguer entre les images : touches page précédente / page suivante  
o Pour faire lancer / arrêter le défilement les images : click droit de la souris 
o Pour zoomer / dézoomer : + / - 
o Pour se déplacer : maintenir le click gauche enfoncé et bouger 
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- Les fonctions principales qui peuvent servir dans les différents menus :  
o File 

 Open Model / Save Model : pour ouvrir un modèle enregistré et 
pour le sauvegarder 

 Set Snap Dir : pour sélectionner le dossier où iront les captures 
d’écran (par défaut : dans le dossier où se trouve le stack) 

o Edit  
 Model > Header : pour définir l’épaisseur (en pixel) entre chaque 

section 
 Exemple : pour les images du 

tutoriel, j’ai des coupes de 50 
nm et un barre d’échelle qui 
dit 1 µm = 1000 nm = 267 px 

 Donc les coupes font 13.35 px 
d’épaisseur. Je rentre cette 
valeur à la ligne Total Z Scale 
(attention, bien un « . » et pas « , ») 

 Object > Type : dans ce menu, on peut choisir si l’objet est ouvert 
ou fermé (Object type Open / Closed), et de quel côté est la surface 
d’intérêt 

 Object > Color, et Object > Delete vont aussi 
servir 

 Contour > Delete et Point > Delete vont aussi 
servir  

o Image  
 ZaP : pour afficher la fenêtre avec le stack (ce qui 

est le cas par défaut) si par exemple, vous l’avez 
fermée par erreur 

 XYZ : vues orthogonales (peut être un moyen de 
vérifier la qualité de l’alignement) 

 Model View : pour afficher le résultat de la 
modélisation. On y reviendra plus tard 

o Special  
 Drawing Tools : les différents outils qui vont 

rendre la segmentation (un peu) plus facile 
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Outils pour la segmentation  

Il y a (heureusement) des outils pour rendre la segmentation plus facile. De manière 
générale, un Object est composé de Contours qui sont composés de Points. Les numéros 
d’object, de contour et de point sont affichés dans la fenêtre de 3dmod. 

Difficile d’expliquer par écrit le ressenti de la segmentation sur IMOD, ou de décrire 
toutes les options. Ce paragraphe inclut les principes généraux et quelques astuces. Tout 
deviendra plus clair avec de la pratique 

- Pour commencer la segmentation, ouvrir le menu Special > 
Drawing Tools 

- Les différentes options sont :  
o Normal : on trace le contour avec la souris 
o Sculpt : on trace un rond, dont on pousse les limites 

pour créer le contour 
o Livewire : 3dmod devine les contours 

- Pour tracer, ça se fait avec en cliquant avec la molette  
o Ce n’est pas le plus pratique : si besoin, il y a la 

possibilité de modifier les commandes de la souris en 
allant sur Edit > Options > onglet Mouse 

- Pour revenir en arrière : Ctrl Z (en cas d'erreur sur un contour, 
ne pas hésiter à l’effacer et recommencer) 

- Pour sélectionner un contour : click gauche dessus  

 

Exemple d’une mitochondrie : 

- En mode Normal, il s’agit de tracer le contour en maintenant la molette enfoncée. 
C’est loin d’être l’option la plus précise ou la moins laborieuse. Avec juste, un clic 
de la molette, on trace un point (ça servira plus loin) 

- En mode Sculpt : on trace un rond avec le clic molette, on peut modifier la taille du 
rond en roulant la molette. Ensuite, en maintenant la molette enfoncée, on « 
pousse » le contour pour l’adapter au limite de la structure que l’on souhaite 
segmenter (une vidéo sera sans doute plus parlante, je vous conseille celle-ci : 
https://youtu.be/BsNSVLIQ-cE ) 
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- En mode Livewire, 3dmod devine le contour. Il suffit de cliquer avec la molette en 
différents points du contour pour tracer le trait. Clore le contour en revenant au 
point de départ. Il y a différentes options : 

o What are you tracing : pour le MET (ou des images 
equivalent MET), Middle of a dark region est approprié 

o Binning : plus le binning est faible, plus la ligne est 
flexible 

o Apply smoothing iterations : lisse le contour (peu 
d’itérations = lissage modéré ; beaucoup d’itérations = 
lissage fort) 

o Préférence personnelle pour binning faible ou 
inexistant, avec un peu de smoothing (2 itérations). 
Jouer un peu avec ces paramètres pour trouver le 
meilleur réglage 

- Ma préférence : tracer les contours de manière préliminaire avec Livewire, puis 
affiner / corriger avec Sculpt 

Quel que soit le mode de tracé choisi, une fois qu’un contour est terminé sur une section, 
on peut passer à la section suivante, et recommencer : un nouveau contour sera créé 
automatiquement. On peut aussi faire, si nécessaire, un deuxième contour (et un troisième…) 
sur une même section. Les numéros des contours importent peu. 

Cas particulier des objets ouverts : 

- Pour les objets ouverts (c’est-à-dire dont les contours ne se ferment pas car ils ne 
sont pas inclus en entier sur les images : exemple du noyau), le principe de la 
segmentation est grosso modo le même 

- La seule différence est liée aux contours : le fait qu’ils ne soient pas fermés peut 
entrainer un certain nombre de petites contraintes sur 3dmod (comme le besoin de 
créer manuellement un nouveau contour à chaque section) 

 

- Une fois qu’un objet est entièrement segmenté, on peut passer au suivant :  
o Edit > Object > New (pas nécessaire pour le premier objet) 
o Faire attention aux contours vides : vérifier s’il 

y a des contours qui n’ont aucun point (avec un 
-x- à la place du nombre de point), et les 
supprimer (Edit > Contour > Delete), ou faire le 
ménage avec la fonction Edit > Object > Clean 

 

- Pour sauvegarder le modèle : File > Save Model As  
o Utiliser un nom qui se termine par .mod : Model.mod par exemple 
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Modélisation 

-  Pour voir les différents contours tracés (et le 
modèle): Image > Model View 

On voit les différents contours qui ont été tracés. On 
peut faire pivoter la vue en maintenant la molette 
enfoncée, et en bougeant la souris 

Options qui peuvent servir : 

- File 
o Snap Tiff As... : pour faire une capture 

d’écran 
o Movie / Montage : pour faire des 

animations de ce qui a été modélisé  
- Edit  

o Objects : voir plus bas 
o Image : permet d’afficher les sections 

et les vues orthogonales (en cliquant 
sur View X/Y/Z image), et de les faire 
défiler avec les tirettes en dessous 

o View > Invert Z : pour inverser l’échelle 
en Z, si jamais 3dmod n’oriente pas la 
série de sections dans le bon sens 

 

Pour la modélisation  

- Edit > Objects : le module pour modéliser les surfaces 
o Sélectionner l’objet à modéliser 
o Meshing, et cliquer sur Mesh One 
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- C’est le moment de vérifier le résultat. S’il y a eu des bugs de la modélisation : 
vérifier et corriger au niveau de la modélisation. Puis revenir au modèle, et cliquer 
à nouveau sur  Mesh One pour prendre les corrections en compte.  
 

- Pour revenir en arrière : Draw > Contours 
- Cliquer sur Skip s’il manque des sections et modéliser malgré les intervalles 

Pour la modélisation du sommet des objets :  

- Il y a l’option Cap que l’on peut utiliser. Le problème, et que ça fermera aussi les 
trous dus au début et fin de stack 

- La solution la moins pire pour clore un objet est de placer un point en haut de la 
structure que l’on veut fermer (Drawing Tools > Normal). Et refaire Mesh One 

 


